java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty

3.14K viewsJavaSpring
0

I am getting this error “java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty” in eclipse
Java 1.8

javax.net.ssl.SSLException: java.lang.RuntimeException: Unexpected error: java.security.InvalidAlgorithmParameterException: 
the trustAnchors parameter must be non-empty

Please advice me.

Changed status to publish
Add a Comment
0

Root cause 1:  Due to low access permissions.
Root cause 2:  Different Java JDK versions path in eclipse.ini.

Example:-

In eclipse.ini file :-

eclipse.vmargs=-Djavax.net.ssl.trustStore=C:\Program Files\Java\jre1.8.0_162\lib\
eclipse.vm=C:\Program Files\Java\jre1.8.0_74\bin\

Check below things :

  • Run Eclipse IDE with higher permissions
  • Check if the Truststore file was available or not in pointed JDK.
  • Don’t put different Java JDK versions paths in eclipse.ini

 

I hope this will help, please try and update me in the comments.

Changed status to publish
Add a Comment
Write your answer.